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 Important Information

Warranty
The media on which you receive National Instruments software are warranted not to fail to execute programming 
instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evidenced 
by receipts or other documentation. National Instruments will, at its option, repair or replace software media that do not 
execute programming instructions if National Instruments receives notice of such defects during the warranty period. 
National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.
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of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully 
reviewed for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves 
the right to make changes to subsequent editions of this document without prior notice to holders of this edition. The 
reader should consult National Instruments if errors are suspected. In no event shall National Instruments be liable for 
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provided herein does not cover damages, defects, malfunctions, or service failures caused by owner’s failure to follow 
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Copyright
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in combination with other products in a manner not evaluated or contemplated by National Instruments, the user or 
application designer is ultimately responsible for verifying and validating the suitability of National Instruments products 
whenever National Instruments products are incorporated in a system or application, including, without limitation, 
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Conventions

The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click on in the software, 
such as menu items and dialog box options. Bold text also denotes 
parameter names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames and extensions, and code excerpts.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value 
that you must supply.
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1
Welcome to VirtualBench

The VirtualBench suite of tools is a high-performance, easy-to-use virtual 
instruments application program for Windows NT/98/95. Getting Started 
with VirtualBench gives you step-by-step instructions on how to use each 
instrument. It also includes a description of the front panel of each 
instrument.

This chapter lists the minimum system requirements for VirtualBench, 
explains how to install VirtualBench, and tells you what the setup program 
installs.

VirtualBench Installation for Windows
You must install VirtualBench along with NI-DAQ driver software.

Minimum System Requirements
To run VirtualBench, you must have the following:

• Microsoft Windows NT 4.0 or higher, Microsoft Windows 98, or 
Windows 95 

• Personal computer using at least a 66 MHz 486 or higher 
microprocessor with floating-point capability (National Instruments 
recommends a Pentium 60 or higher microprocessor with 
floating-point capability)

• VGA resolution (or higher) video adapter

• Minimum of 16 MB of RAM

• 30 MB free hard disk space

• Microsoft-compatible mouse

• NI-DAQ 6.5 or later 

You cannot use the current version of VirtualBench in either of these cases:

• You are using Windows 3.1.x.

• You are using an AT-DSP2200, AT-2150, or EISA-A2000 DAQ device 
in Windows NT or Windows 95.
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In these cases, you must use VirtualBench 2.0, located in the vbench20 
folder on the VirtualBench CD. For more information on installing 
VirtualBench 2.0, consult the readme.txt file in the vbench20\WIN31 or 
vbench20\WIN95-NT folders.

Installing VirtualBench

Note National Instruments recommends that you close other applications before you 
install VirtualBench.

To install VirtualBench, perform the following steps:

1. Insert your VirtualBench Installation CD into your CD-ROM drive.

2. Wait several seconds. On most computers, the AutoRun utility on the 
CD automatically launches the VirtualBench Installation CD dialog 
box.

3. If the VirtualBench Installation CD dialog box does not appear, use 
the Start button in the Windows taskbar to select Run, and type 
d:\setup in the input box, where d is your CD-ROM drive. Click 
on OK. 

4. Click on Install VirtualBench in the VirtualBench Installation CD 
dialog box.

What the Setup Program Installs
The VirtualBench setup program installs the following virtual instruments, 
with online help for each instrument:

• Oscilloscope (Scope)

• Dynamic signal analyzer (DSA)

• Function generator (FG)

• Logger

• Arbitrary waveform generator (Arb)

• Waveform editor (Arb)

• Device calibrator (CAL)
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Installing on a Network 
Contact National Instruments for licensing information if you plan to run 
VirtualBench on a network.

Note Be sure to view the VirtualBench readme.txt file on the VirtualBench installation 
CD for the latest information concerning the installation and use of VirtualBench.

Connecting Signals to Your Data Acquisition Device
Refer to the user manual for your National Instruments DAQ device for 
instructions on connecting signals to your device.
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2
VirtualBench-Scope

This chapter explains the VirtualBench oscilloscope (Scope) front panel 
features and how to acquire data with the oscilloscope.

Launching VirtualBench-Scope
To launch VirtualBench-Scope, use the Start button in the Windows 
taskbar to select Programs»VirtualBench»VirtualBench-Scope.

Front Panel Features
This section explains the features of the VirtualBench-Scope front panel, 
shown in Figure 2-1.
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Figure 2-1.  Front Panel of VirtualBench-Scope

The front panel of VirtualBench-Scope has the following features:

• Channel Selector—Selects a waveform for display on the graphics 
display.

• Channel Settings

– Channel—Selects the active channel.

– Volts/div—Adjusts the vertical sensitivity of the active channel.

– Coupling—Selects AC or CD input coupling.

– V. Position—Moves the active channel vertically on the graph.

• Timebase—Controls the timebase setting. Turning the knob 
clockwise reduces the time period that appears in the graphics display. 
Each horizontal division represents one time period.

• Trigger Cursor—Changes the trigger level and position. Move the 
trigger cursor by clicking and dragging the cursor on the display.

Channel Selector

Timebase

Zoom Controls

Channel
Settings

Trigger
Settings
Group

Main Control Bar

Graphics
Display

Trigger Cursor Vertical Sliders

Maximize/Minimize
Graphics Display



Chapter 2 VirtualBench-Scope

© National Instruments Corporation 2-3 Getting Started with VirtualBench

• Graphics Display—Displays waveforms, channel information, 
cursor, and waveform measurements.

• Maximize/Minimize Graphics Display—Maximizes the graphics 
display so that it fills the entire window.

• Vertical Sliders—Adjust voltage offset for each channel. Use a slider 
when you want to adjust multiple waveforms in the graphics display.

• Trigger Settings Group—Controls the conditions required for signal 
acquisition; for example, whether to wait for a digital trigger before 
acquiring data or whether to acquire data in free-run mode 
(no triggering).

• Main Control Bar Buttons

– Run—Acquires data continuously. Deselection of this button 
places the VirtualBench-Scope in idle mode.

– Single—Instructs VirtualBench-Scope to perform a single 
acquisition.

– Auto Setup—Configures the scope for the best timebase, volts 
per division, and trigger setting for each channel currently 
selected with the channel selector.

– Mode—Sets the mode of the scope to either volts versus time or 
X versus Y mode.

– Select—Selects a subset of the waveform for further analysis or 
for saving to disk.

• Zoom Controls—Adjusts the view of your display data.

– Scroll Bar—Adjusts zoom view.

– Zoom In—Zooms in on display data. Each zoom increases the 
view by a factor of two.

– Zoom Out—Zooms out to full X scale.

Note Refer to VirtualBench-Scope Online Reference for additional help on the front panel 
items.
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Acquiring Data
When you launch VirtualBench-Scope, it operates in continuous run mode. 
To start acquiring signals with VirtualBench-Scope, complete the 
following steps:

1. If you are using a DAQ device, connect a signal to the Channel 0 input 
of your device. Refer to the user manual of your DAQ device for 
details. For example, on a 68-pin MIO E-series device, connect a signal 
to pins 68 (ACH0) and 67 (AIGND) for a Referenced Single-Ended 
input.

If you are using an IVI device, connect a signal to the appropriate 
channel of your device.

2. Configure VirtualBench-Scope.

a. Select General Settings from the Edit menu on the front panel.

b. Select the National Instruments DAQ or IVI instrument you want 
to use from the Acquire tab of the Scope Settings dialog box, 
shown in Figure 2-2. If a device does not appear in the Instrument 
list, make sure you have properly configured the instrument using 
the Measurement & Automation Explorer, or that you have 
configured an IVIScope virtual instrument in the Measurement & 
Automation Explorer. Please refer to Chapter 4, Configuring Your 
System, in the IVI Driver Library User Manual for more 
information on configuring your IVI virtual instrument.
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Figure 2-2.  General Tab of VirtualBench-Scope Settings Dialog Box

c. Click on OK to use these settings.

Note When you launch VirtualBench-Scope, it automatically uses the settings of your 
previous VirtualBench-Scope session.

3. Enable the button for the connected channel in the Channel Selector 
group. Disable all other channels.

4. Click on AutoSetup on the main control bar.

5. To change the trigger position, drag the trigger cursor (the small green 
cursor in the center of the graph).

6. Click on Run to stop the acquisition.

Note Refer to VirtualBench-Scope Online Reference for additional help on configuring 
VirtualBench-Scope for your specific application.
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3
VirtualBench-DSA

This chapter explains the front panel features of the VirtualBench dynamic 
signal analyzer (DSA) and how to acquire and measure signals. 

Launching VirtualBench-DSA
To launch VirtualBench-DSA, use the Start button in the Windows taskbar 
to select Programs»VirtualBench»VirtualBench-DSA or click on the 
DSA button on the VirtualBench toolbar.

Front Panel Features
This section explains the features of the VirtualBench-DSA front panel, 
shown in Figure 3-1.
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Figure 3-1.  Front Panel of VirtualBench-DSA

The front panel of VirtualBench-DSA has the following features:

• Display Settings Control—Provides individual control of the 
measurements VirtualBench-DSA performs on each display. You can 
select the channels, function, magnitude/phase mode, magnitude unit, 
log/linear mode, phase unit, and markers for a display.

• Main Control Bar Buttons—Contains the Run, Single, and Pause 
controls.

– Run—Acquires data continuously. Deselecting this button places 
VirtualBench-DSA in idle mode.

– Single—Acquires a single frame of data.

– Pause—Pauses the acquisition. Pausing does not clear the 
averaging buffers. 

• Measurement Displays—Displays measurements, reference 
waveforms, and markers for marker measurements.

Main Control Bar
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Note VirtualBench-DSA Online Reference provides additional help on the front 
panel items.

Acquiring and Measuring Signals
To start acquiring and measuring signals with VirtualBench-DSA, follow 
these steps:

1. Connect a signal to the Channel 0 or 1 input of your DAQ device. Refer 
to the user manual of your DAQ device for details.

2. Configure the DSA.

a. Select Input Settings from the Edit menu on the front panel.

b. Select the Input tab from the DSA Settings dialog box, shown in 
Figure 3-2.

Figure 3-2.  Input Tab of DSA Input Settings Dialog Box

c. Select the device that you want to use for the data acquisition. The 
Device list displays only devices that you have configured 
successfully in the Measurement & Automation Explorer.

d. Click on the Triggering tab in the DSA Settings dialog box, shown 
in Figure 3-3.
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Figure 3-3.  Triggering Tab of DSA Input Settings Dialog Box

e. Set the Trigger Type to none. This setting puts the acquisition in 
free-run mode.

f. Click on OK.
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g. Select Frequency Settings in the Edit menu on the front panel.

h. Select the Span tab in the Frequency Settings dialog box.

Figure 3-4.  Span Tab of DSA Frequency Settings Dialog Box

3. Select a Baseband Span that is appropriate to the signal that you are 
trying to measure. Then click on OK.

4. In the upper display on the front panel, select Time Waveform in the 
Waveform Type pop-up menu. Choose Linear Magnitude in the Scale 
pop-up menu. 

5. Select Markers None in the Markers pop-up menu.

6. In the lower display on the front panel, select Power Spectrum in the 
Waveform Type pop-up menu. Choose Log Magnitude in the Scale 
pop-up menu.

7. Click on the Single button. VirtualBench-DSA displays a single frame 
of data. If no data is visible, click on the Autoscale Y Axis button (the 
button that contains a “y” and up/down arrows) in the display control. 
Check your signal connections if data still does not appear.

8. Click on Run. VirtualBench-DSA continuously acquires and displays 
frames of data.

9. Click on Run again to stop acquisition.

Note Refer to the VirtualBench-DSA Online Reference for additional help on configuring 
VirtualBench-DSA for your specific application.
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4
VirtualBench-Logger

This chapter explains the VirtualBench-Logger front panel features and 
how to acquire data with the logger.

Launching VirtualBench-Logger
To launch VirtualBench-Logger, use the Start button in the Windows 
taskbar to select Programs»VirtualBench»VirtualBench-Logger or 
click on the Logger button on the VirtualBench toolbar.

Front Panel Features
This section explains the features of the VirtualBench-Logger front panel, 
shown in Figure 4-1.
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Figure 4-1.  Front Panel of VirtualBench-Logger

The front panel of VirtualBench-Logger has the following features:

• Strip Chart Display—Displays the logged data.

• Y Axis Select Controls—Selects which channel’s Y scale to display 
on either the left or right Y axis of the strip chart display.

• Status Display—Shows the current time, start time, and stop time of 
the current data acquisition.

• Channel Select Control—Selects which channels to display on the 
strip chart display. You can use the Labels/Values radio buttons below 
the channel select control to switch between the channel labels and the 
channel values.

• Legend Control—Changes the trace attributes of each display 
channel. Clicking on a trace in the legend control brings up a menu that 

Y Axis
Select
Control

Status
Display

Strip Chart
Display

Legend
Control

Channel
Select

Acquire Data Controls Performance Indicator
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allows you to make changes to the point style, line style, interpolation 
method, and color of the trace.

• Acquire Data Controls

– Logging On/Off—Starts or stops logging of data to disk when 
you run the instruments.

– Clear Chart—Clears the strip chart display. Clicking on this 
button does not affect the acquisition of data.

– Start—Starts the acquisition of data using the current logger 
configuration.

– Stop—Stops the acquisition of data and data logging when 
enabled.

– Pause—Temporarily stops the flow of data to the strip chart and 
log file when enabled.

• Performance Indicator—Shows how efficiently 
VirtualBench-Logger runs when acquiring data. Try to keep 
VirtualBench-Logger running as efficiently as possible. As the 
performance decreases, the indicator turns red to indicate poor 
performance. When the performance reaches zero, an error message 
pops up, and the Logger stops collecting data.

Note Refer to VirtualBench-Logger Online Reference for additional help on the front 
panel items.

Acquiring Data
To start acquiring data with VirtualBench-Logger, follow these steps:

1. Connect several known voltage signals to the input channels of your 
DAQ device. Refer to the user manual of your DAQ device for details. 
National Instruments recommends that you use known reference 
signals to verify proper operation of VirtualBench-Logger and your 
DAQ device.

2. Configure VirtualBench-Logger.

a. Select Settings from the Edit menu on the front panel.

b. Select the device and SCXI Module that you want to use 
in the Logger Settings dialog box, shown in Figure 4-2. 
VirtualBench-Logger disables the SCXI Module list when 
no SCXI modules are configured for the selected device. The 
Device list displays only devices that you have configured 
successfully in the Measurement & Automation Explorer.
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Figure 4-2.  Logger Settings Dialog Box

Note The options on the Logger Settings dialog box vary slightly if you use a 4350 Series 
board. Refer to VirtualBench-Logger Online Reference for more information.

c. Set the Start and End Channel appropriately for the channels that 
you connected signals to in Step 1.

d. Set the channel attributes for each channel from the Start Channel 
to the End Channel. Give each channel an appropriate label for 
easy identification on the strip chart display.

e. Click on the File Config… button. In the File Configuration 
dialog box, shown in Figure 4-3, specify the name of the log file 
where VirtualBench-Logger stores the logged data on disk. To 
specify the location of this file, use the Browse button. Select 
Enable Logging and Begin Logging on Start. Click on OK.

Note If you have not previously specified a log file, VirtualBench-Logger automatically 
displays a File dialog box.
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Figure 4-3.  File Configuration Dialog Box

f. Click on the Timing Config button. In the Timing Configuration 
dialog box, shown in Figure 4-4, set the Start Timing and Stop 
Timing to start and stop manually. Set the Time Interval to 1.00 
seconds. Set the Display Length to 1 minute. Set Log to Disk 
Every n Time Intervals to 1. Click on OK.

Figure 4-4.  Timing Configuration Dialog Box
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g. Click on OK in the Logger Settings dialog box to return to the 
front panel.

3. Select the channels that you want to display on the strip chart using the 
channel select control.

4. Click on the right or left y-axis controls to select which channel’s 
y-scale you want to display on the strip chart.

5. Click on Start in the acquire data controls area. VirtualBench-Logger 
begins acquiring and logging data to disk at one-second intervals and 
displays it on the strip chart. If no data appears, check the signal 
connections to your DAQ device or check the Range limits for the 
channels you selected in the Logger Settings dialog box.

6. Click on the Stop button to stop the acquisition.

Note Refer to VirtualBench-Logger Online Reference for additional help on configuring 
VirtualBench-Logger for your specific application.
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5
VirtualBench-FG

This chapter explains the VirtualBench function generator (FG) front panel 
features and how to generate a waveform.

Launching VirtualBench-FG
To launch VirtualBench-FG, use the Start button in the Windows taskbar 
to select Programs»VirtualBench»VirtualBench-FG or click on the 
FG button on the VirtualBench toolbar.

Front Panel Features
This section explains the features of the VirtualBench-FG front panel, 
shown in Figure 5-1.

Figure 5-1.  Front Panel of VirtualBench-FG

Display Window Range Selector Function Selector

Waveform Modifier ControlsFrequency KnobOn Play
List

Step
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The front panel of VirtualBench-FG has the following features:

• Display Window—Shows the actual waveform frequency 
VirtualBench-FG generates.

• Range Selector—Selects the frequency range of VirtualBench-FG.

• Function Selector—Selects which type of waveform 
VirtualBench-FG generates.

• Frequency Knob—Controls the frequency of the waveform within 
the range range selector specifies.

• Waveform Modifier Controls—Modifies some of the properties of 
the waveform.

– Duty Cycle—Adjusts the duty cycles of the sine wave, square 
wave, and triangle wave.

– Offset—Adjusts the DC offset of the waveform.

– Amplitude—Adjusts the peak amplitude of the generated 
waveform.

• On—Starts or stops waveform generation.

• Play List—Outputs waveforms as specified in the frequency list. 
The Play List button appears only with 54xx devices.

• Step—Steps through the frequency list. The Step button appears only 
with 54xx devices.

Note Refer to VirtualBench-FG Online Reference for additional help on the front panel 
items.

Generating a Waveform
To configure VirtualBench-FG to generate a waveform, perform the 
following steps.

1. Configure the output.

a. Select Settings from the Edit menu on the front panel.

b. Select the instrument that you want to use for waveform 
generation in the VirtualBench-FG Settings dialog box, shown in 
Figure 5-2. The Device list displays only devices that you have 
configured successfully in the Measurement & Automation 
Explorer. Please refer to Chapter 4, Configuring Your System, in 
the IVI Driver Library User Manual for more information on 
configuring your IVI virtual instrument.
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Figure 5-2.  VirtualBench-FG Settings Dialog Box

c. Set the channel.

d. Click on OK.

2. Connect a device or scope to the output of the analog output device that 
you specified in Step 1. Refer to your DAQ device user manual or 
instrument manual for details.

3. Click on On. VirtualBench-FG continuously generates an analog 
waveform at the output pin.

4. Click on On again to stop the waveform generation.

Note Refer to VirtualBench-FG Online Reference for additional help on configuring 
VirtualBench-FG for your specific application.
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6
VirtualBench-DMM

This chapter explains the VirtualBench digital multimeter (DMM) and how 
to measure a signal with the DMM.

Launching VirtualBench-DMM
To launch VirtualBench-DMM, use the Start button in the Windows 
taskbar to select Programs»VirtualBench»VirtualBench-DMM.

Front Panel Features
This section explains the features of the VirtualBench-DMM front panel, 
shown in Figure 6-1.

Figure 6-1.  Front Panel of VirtualBench-DMM
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The front panel of VirtualBench-DMM has the following features:

• Measurement Display—Displays measurements.

• Mode Selector—Selects which measurement mode you want to use. 
The modes, from left to right, are as follows:

– Volts AC—Measures the AC component of a voltage signal.

– Volts DC—Measures the DC component of a voltage signal.

– Current AC—Measures the AC component of a current source.

– Current DC—Measures the DC component of a current source.

– Ohms—Measures resistance.

– 4-Wire Ohms—Measures resistance using four-wire method.

– Diode—Measures the voltage drop across a diode.

– Temperature—Measures temperature. 

• Resolution Control—Selects the number of digits of resolution.

• Range Selector—Determines the measurement range. This range is 
different for each measurement mode. AutoRange mode selects the 
best range to fit the input signal.

• Main Control Buttons

– Run—Starts or stops the DMM acquisition.

– Single—Acquires a single measurement.

– Log—Enables logging.

• Math Control Buttons

– Null—Selects relative mode. When you click on this button, all 
subsequent measurements become relative to the measurement 
made when you pressed this button.

– Max/Min—Displays the maximum and minimum values since 
you first clicked on the button.

– mX+B—Manipulates normal display readings (X) according to 
the calculation mX+B.

– dB—Displays the decibel value of your signal.

– dBm—Displays the decibel power level with respect to one mW.

– %—Displays the current value as a percentage of a reference.

Note Refer to VirtualBench-DMM Online Reference for additional help on the front panel 
items.
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Measuring a Signal
To start measuring signals with VirtualBench-DMM, follow these steps:

1. Configure VirtualBench-DMM.

a. Select Settings from the Edit menu on the front panel.

b. Select the General tab, shown in Figure 6-2.

Figure 6-2.  General Tab of VirtualBench-DMM Settings Dialog Box

c. Select the instrument that you want to use. VirtualBench-DMM 
hides the SCXI Module list when no SCXI modules are 
configured for the selected device. The Device list displays only 
devices that you have configured successfully in the Measurement 
& Automation Explorer.

d. Set the channel to the source of your signal.

e. Click on OK.

2. Measure voltage. VirtualBench-DMM measures AC and DC voltage 
without any external hardware.

a. Connect a signal to the Channel input that you specified in Step 1. 
Refer to the user manual of your DAQ device for details.

b. Click on the Volts AC or Volts DC button in the Mode selector. 
VirtualBench-DMM continuously acquires and displays voltage 
measurements in the display window.
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c. If the DMM display shows +CLIP or –CLIP, confirm that the input 
signal does not exceed the range of your DAQ device and that the 
input signal does not exceed the selected range.

d. Click on Run to stop the measurement.

3. Measure current. If you are using an NI 4060 PCI/PXI-based 
multimeter or an IVI instrument, skip to Step 3g.

If you are using any other device, VirtualBench-DMM requires a 
precision external shunt resistor to measure current. To configure your 
precision external shunt, follow these steps:

a. Connect a precision shunt resistor across the input of the Channel 
that you specified in Step 1. Refer to the user manual of your DAQ 
device for details.

b. Connect your current signal to the same terminals.

c. Select Settings from the Edit menu on the front panel.

d. Select the Current and Resistance tab, shown in Figure 6-3.

Figure 6-3.  Current and Resistance Tab of VirtualBench-DMM Settings Dialog Box

e. Enter the value of the shunt resistor in the Current Shunt Resistor 
Control.

f. Click on OK.
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g. Click on the Current AC or Current DC button in the Mode 
selector, depending on which type of voltage you connected in 
Step 3b. 

h. Click on Run. VirtualBench-DMM continuously acquires and 
displays current measurements in the display window.

i. If the DMM display shows +CLIP or –CLIP, confirm that the input 
signal does not exceed the range of your DAQ device or IVI 
instrument and that the input signal does not exceed the selected 
range.

j. Click on Run again to stop the measurement.

4. Measure resistance. If you are using an NI 4060 PCI/PXI-based 
multimeter, a DAQMeter DAQCard-4050, or an IVI device, skip to 
Step 4g. 

If you are using any other device, you must use a precision external 
current source to measure resistance. To configure your current source, 
follow these steps:

a. Connect a precision current source to the channel that you 
specified in Step 1. Refer to the user manual of your DAQ device 
for details.

b. Connect the resistor you want to measure across the same 
terminals.

c. Select Edit»Settings on the front panel.

d. Select the Current and Resistance tab.

e. Enter the value of the current source in the Current Source 
Control.

f. Click on OK.

g. Click on the Ohms button in the Mode selector.

h. Click on Run. VirtualBench-DMM continuously acquires and 
displays resistance measurements in the display window.

i. If the DMM display shows +CLIP or –CLIP, confirm that the input 
signal does not exceed the range of your DAQ device or IVI 
instrument and that the input signal does not exceed the selected 
range.

j. Click on Run again to stop the measurement.
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5. Measure temperature. VirtualBench-DMM requires a thermistor, 
IC sensor, or thermocouple to make precise temperature 
measurements. If you are using a DAQMeter DAQCard-4050 or an 
NI 4060 PCI/PXI-based multimeter, you cannot use 
VirtualBench-DMM to make temperature measurements.

a. Connect a precision temperature sensor to the channel that you 
specified in Step 1. Refer to the user manual of your DAQ device 
for details.

b. Select Settings from the Edit menu on the front panel.

c. Select the Temperature tab, shown in Figure 6-4.

Figure 6-4.  Temperature Tab of VirtualBench-DMM Settings Dialog Box

d. Select the type of sensor from the Temperature Sensor list that you 
connected to the channel specified in Step 1a. 

e. Select the Temperature Units you want for the temperature 
display.

f. Select the cold junction sensor type from the TC Cold Junction 
Source list when you use a thermocouple. Select the channel to 
which the cold junction sensor is connected.

g. Click on OK.

h. Click on the Temperature button in the Mode selector.
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i. Click on Run. VirtualBench-DMM continuously acquires and 
displays temperature measurements in the display window.

j. If the DMM display shows +CLIP or –CLIP, confirm that the input 
signal does not exceed the range of your DAQ device and that the 
input signal does not exceed the selected range.

k. Click on Run again to stop the measurement.

6. Measure a diode. If you are using a DAQMeter DAQCard-4050 or an 
NI 4060 PCI/PXI-based multimeter, you can measure the voltage drop 
across a diode, up to 2 V. If you are using an IVI instrument, you can 
also measure diode voltage if the instrument supports this.

a. Connect the diode to the terminals of the DAQCard-4050.

b. Click on the Diode button in the Mode selector.

c. Click on Run.

d. Click on Run again to stop the measurement.

Note Refer to the VirtualBench-DMM Online Reference for additional help on 
configuring VirtualBench-DMM for your specific application.
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7
VirtualBench-Power Supply

This chapter explains the front panel features of the VirtualBench-Power 
Supply and how to turn on VirtualBench-Power Supply.

Launching VirtualBench-Power Supply
To launch VirtualBench-Power Supply, select Programs»VirtualBench» 
VirtualBench-Power Supply in the Start button of the Windows taskbar.

Front Panel Features
This section describes the VirtualBench-Power Supply front panel.

Figure 7-1.  Front Panel of VirtualBench-Power Supply
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The front panel of VirtualBench-Power Supply has the following features:

• Graphics Display—Shows real-time voltage and current 
measurements, if your instrument supports these measurements. If 
your device does not support these measurements, the display shows 
your current settings. “OVP” indicates that the over-voltage protection 
circuitry has tripped. “OCP” indicates that the over-current protection 
circuitry has tripped.

• Volts DC—Allows you to set the power supply to a specified DC 
voltage.

• Volts AC—Allows you to set the power supply to a specified AC 
voltage, with optional settings such as waveform shape, frequency, 
amplitude, DC offset, and start phase.

• Limits—Allows you to specify upper and lower voltage limits and a 
current limit, and enable over-voltage or over-current protection 
circuitry.

• Apply—Commits changes you have made to front panel controls.

• Output On/Off—Enables output of the Power Supply.

Note Refer to VirtualBench-Power Supply Online Reference for additional help on the 
front panel items.

Turning on the Power Supply
When you launch VirtualBench-Power Supply, it always launches in a 
power off state. You must configure VirtualBench-Power Supply before 
using it:

1. Connect a load to one of the output channels of your power supply.

2. Configure VirtualBench-Power Supply.

a. Select Settings from the Edit menu on the front panel.

b. Select the IVI instrument’s logical name that you want to use. 
If you have not already configured a logical name for your 
instrument, VirtualBench-Power Supply has already created one 
for you with the same name as the virtual instrument installed in 
your system. For details, see the Changing the Items to which 
Another Item Refers section in Chapter 4, Configuring Your 
System, of the IVI Driver Library User Manual.

c. Select the channel you want to use.
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Figure 7-2.  Power Supply Settings Configuration

d. Click on OK to use these settings.

To generate a DC power signal, complete these steps:

1. Click on the Volts DC button to select DC volts mode.

Figure 7-3.  Front Panel with Volts DC Button Selected
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2. Enter a voltage in the Voltage control.

3. Click on Apply to commit to the change. If a red error button appears 
in the display window, click on the button to display the cause of the 
error. Adjust the voltage level if necessary.

4. Click on Output to enable the power supply.

To generate an AC power signal, complete these steps:

1. Click on the Volts AC button to select AC volts mode.

Figure 7-4.  Front Panel with Volts AC Button Selected

2. Enter the appropriate settings for your AC signal.

3. Click on Apply to commit to the change. If a red error button appears 
in the display window, click on the button to display the cause of the 
error. Adjust the settings if necessary.

4. Click on Output to enable the power supply.

To exit VirtualBench-Power Supply, select Exit from the File menu. 
VirtualBench-Power Supply saves your current settings for the next 
session.
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8
VirtualBench-Switch

This chapter explains the VirtualBench-Switch front panel features and 
how to make signal connections.

Launching VirtualBench-Switch
To launch VirtualBench-Switch, use the Start button in the Windows 
taskbar to select Programs»VirtualBench»VirtualBench-Switch.

Front Panel Features
This section explains the features of the VirtualBench-Switch front panel, 
shown in Figure 8-1.
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Figure 8-1.  Front Panel of VirtualBench-Switch

The front panel of VirtualBench-Switch has the following features:

• Instrument Selector—Allows you to select the IVI instrument you 
want to use.

• Channel Selection Group—Allows you to choose two channels to 
connect.

• Connection List—Allows you to view details and disconnect any 
existing connection.

• Status Display—Displays the connection path of the selected 
connection, channel information such as maximum current, voltage, 
and power capacity, information on why two channels cannot be 
connected, and any error information.
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Note Refer to VirtualBench-Switch Online Reference for additional help on the front 
panel items.

Making Connections
When you launch VirtualBench-Switch, it automatically assumes the 
settings of your previous VirtualBench-Switch session. To make signal 
connections, complete the following steps:

1. Connect signals to two or more channels on your switch instrument.

2. Select the IVI instrument’s logical name that you want to use. If you 
have not already configured a logical name for your instrument, 
VirtualBench-Switch has already created one for you with the same 
name as the virtual instrument installed in your system. For details, see 
the Changing the Items to which Another Item Refers section in 
Chapter 4, Configuring Your System, of the IVI Driver Library User 
Manual.

3. Select two channels that you want to connect in the Channel Selection 
Group. 

4. Click on Connect to connect the two channels.

5. Click on the connection in the connection list to view information 
about the connection.

To disconnect a signal connection, click on the connection in the 
connection list and then click on Disconnect.

To save a group of connections, select Save Settings from the Edit menu. 
Enter the name of the file you want to save, such as MySetup.swh.

To exit VirtualBench-Switch, select Exit from the File menu. 
VirtualBench-Switch saves your current settings for the next session.
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9
VirtualBench-Arb

This chapter explains the VirtualBench Arbitrary Waveform Generator 
front panel features, the Waveform Editor front panel features, and how to 
generate a waveform.

Launching VirtualBench-Arb
To launch VirtualBench-Arb, which contains the Waveform Generator and 
Waveform Editor, use the Start button in the Windows taskbar to select 
Programs»VirtualBench»VirtualBench-Arb or click on the Arb button 
on the VirtualBench toolbar.

Waveform Generator Front Panel Features 
This section explains the features of the VirtualBench-Arb Waveform 
Generator front panel, shown in Figure 9-1.

Figure 9-1.  Front Panel of VirtualBench-Arb Waveform Generator
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The Waveform Generator front panel of VirtualBench-Arb has the 
following key features:

• Waveform Name/Load Waveform Control—Shows the name of 
the waveform file, if any, for VirtualBench-Arb to generate. Select this 
window to load a waveform from a file.

• Mode—Plays the waveform continuously. Deselecting this button 
plays the waveform only once.

• Update Rate—Controls the update rate of the waveform. This control 
does not affect the play speed of waveform files (.wfm) but does affect 
waveform quality. With text, binary, and sound (.wav) files, the update 
rate determines the play speed by controlling the number of samples of 
the waveform that VirtualBench-Arb plays per second.

• Amplitude Control—Scales the waveform by the specified amount.

• Step—Steps through the stages in a waveform sequence. 
VirtualBench-Arb enables this button only for 5411 devices.

• Play/Stop Control—Starts or stops waveform generation for one 
channel.
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Waveform Editor Front Panel Features
This section explains the features of the VirtualBench-Arb Waveform 
Editor front panel, shown in Figure 9-2.

Figure 9-2.  Front Panel of VirtualBench-Arb Waveform Editor

The Waveform Editor front panel of VirtualBench-Arb has the following 
features:

• View Control—Selects the waveform view to display on the graph. 
Waveform displays the entire waveform. Segment displays the 
selected segment. Component displays the selected component.

• X Axis Control—Selects the X axis units. Time displays the 
waveform as a function of time. Frequency displays the power 
spectrum of the waveform.

• Units Control—Selects the active units you are currently using for the 
display and control values.

• Style Control—Changes the graph attributes.
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• Segment List Box—Selects the segment or component you want to 
edit. A number precedes a segment and indicates a unique section of 
the waveform. The value in parentheses indicates the segment length. 
Indented text in the list box represents a waveform component.

• New Segment Button—Inserts a new waveform segment 
immediately after the current selection.

• New Component Button—Inserts a new component immediately 
after the current selection.

• Component Type Control—Selects the type of component. A 
waveform Library function is one of 20 predefined waveform patterns. 
An Expression is a single-variable function evaluated over an interval. 
A Sketch is a waveform you draw with a mouse.

Note VirtualBench-Arb Online Reference provides additional help for the front panel 
items.

Generating a Waveform
To start generating waveforms with VirtualBench-Arb, follow these steps:

1. Configure VirtualBench-Arb.

a. Select Settings from the Edit menu on the front panel.

b. Select the Channels tab, shown in Figure 9-3.

Figure 9-3.  Channels Tab of VirtualBench-Arb Settings Dialog Box
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c. Select the device that you want to use for waveform generation. 
The Device list displays only devices that you have configured 
successfully in the Measurement & Automation Explorer.

d. Select the corresponding DAQ device channels to map to the 
VirtualBench-Arb alphabetical channel names.

e. Click on OK.

2. Create a new waveform.

a. Select Window»Waveform Editor.

b. Enter the duration of the waveform in the Duration control to set 
the duration of the first segment.

c. Click on New Component. By default, every time you click on 
New Component, VirtualBench-Arb adds a new library 
component to any existing waveform. 

d. Select the type of component: Library, Expression, or Sketch. 
The following steps further describe how to use these options.

3. Create a waveform using the library functions.

a. Confirm that you selected Library in the Component Type 
control.

b. Select a waveform from the library and modify the parameters if 
necessary.

c. Click on New Component again to add a new component. This 
component adds to the first to produce the final segment. Change 
the Function selector to perform subtraction, multiplication, 
division, or frequency modulation.

d. Click on New Segment to add additional waveform segments to 
the end of the waveform.

4. Create a waveform from a mathematical expression.

a. Click on on New Segment to create a new segment.

b. Click on New Component to create a new component in the 
segment.

c. Select Expression from the component type control.

d. Enter an expression in terms of variable x in the f(x)= box. 
VirtualBench-Arb indicates any error in red, with the character 
position of the error in parentheses.

e. Enter the range for x in the From: and To: input boxes. 
VirtualBench-Arb evaluates the expression over this range. 
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f. To change the number of cycles of the waveform, change the 
Cycles control.

5. Create a waveform from a freehand sketch.

a. Click on on New Segment to create a new segment.

b. Click on New Component to create a new component in the 
segment.

c. Select Sketch from the component type control.

d. Click on Draw. Notice that this changes from View to 
Component mode so that VirtualBench-Arb displays only the 
current component.

e. Click and drag over the graph using the mouse to create a 
waveform. Click on the Mode button to change the mode to line. 
This mode allows you to draw straight lines.

f. Click on Draw again to finish editing.

6. Select File»Save to save your waveform.

7. Close the Waveform Editor front panel.

8. In the front panel of the Waveform Generator, click on the Load 
Waveform button to invoke the file selection dialog box. Select the 
waveform file that you saved in Step 6.

9. Adjust the Rate control to an appropriate update rate. Select a rate that 
is at least twice the maximum frequency component of your signal.

10. Click on the Play button (the button containing a green triangle) to 
begin waveform generation.

11. Click on the Stop button (the button containing a red square) to end 
signal generation.

Note Refer to VirtualBench-Arb Online Reference for additional help on configuring 
VirtualBench-Arb for your specific application.
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10
VirtualBench-Device Calibrator

This chapter explains the VirtualBench-Device Calibrator front panel 
features and how to calibrate a DAQ device.

Launching VirtualBench-Device Calibrator
To launch the VirtualBench-Device Calibrator, use the Start button in the 
Windows taskbar to select Programs»VirtualBench»VirtualBench Cal 
or click on the Cal button on the VirtualBench toolbar.

Front Panel Features
This section explains the front panel features of the 
VirtualBench-Device Calibrator, shown in Figure 12-1.

Figure 10-1.  Front Panel of VirtualBench-Device Calibrator
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The front panel of the VirtualBench-Device Calibrator has the following 
features:

• Device List—Shows all the devices installed in your computer that are 
self-calibrating and the last calibrated date. The Device list displays 
only devices that you have configured successfully in the 
Measurement & Automation Explorer.

• Calibrate Button—Begins the calibration process.

You can use the VirtualBench-Device Calibrator to calibrate the 
analog input circuitry of the following DAQ devices: E-series, 
AT-MIO-16F-5, AT-MIO-64F-5, AT-MIO-16X, and PC-LPM-16. 
Special connections are not necessary; VirtualBench-Device Calibrator 
automatically accesses the calibration features of these devices.

Calibrating a DAQ Device
To calibrate your device with VirtualBench-Device Calibrator, follow 
these steps:

1. Wait at least 15 minutes after you turn on both your computer and 
device before calibrating your device.

2. Select the device you want to calibrate from the Device list.

3. Click on Calibrate. Calibration of your device may take up to 
20 seconds.

4. Wait for calibration to complete before using any other VirtualBench 
instrument. 

Note Refer to VirtualBench-Device Calibrator Online Reference for additional help on 
configuring VirtualBench-Device Calibrator for your specific application.
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A
Technical Support Resources

This appendix describes the comprehensive resources available to you in 
the Technical Support section of the National Instruments Web site and 
provides technical support telephone numbers for you to use if you have 
trouble connecting to our Web site or if you do not have internet access.

NI Web Support
To provide you with immediate answers and solutions 24 hours a day, 
365 days a year, National Instruments maintains extensive online technical 
support resources. They are available to you at no cost, are updated daily, 
and can be found in the Technical Support section of our Web site at 
www.natinst.com/support.

Online Problem-Solving and Diagnostic Resources
• KnowledgeBase—A searchable database containing thousands of 

frequently asked questions (FAQs) and their corresponding answers or 
solutions, including special sections devoted to our newest products. 
The database is updated daily in response to new customer experiences 
and feedback.

• Troubleshooting Wizards—Step-by-step guides lead you through 
common problems and answer questions about our entire product line. 
Wizards include screen shots that illustrate the steps being described 
and provide detailed information ranging from simple getting started 
instructions to advanced topics.

• Product Manuals—A comprehensive, searchable library of the latest 
editions of National Instruments hardware and software product 
manuals.

• Hardware Reference Database—A searchable database containing 
brief hardware descriptions, mechanical drawings, and helpful images 
of jumper settings and connector pinouts.

• Application Notes—A library with more than 100 short papers 
addressing specific topics such as creating and calling DLLs, 
developing your own instrument driver software, and porting 
applications between platforms and operating systems.
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Software-Related Resources
• Instrument Driver Network—A library with hundreds of instrument 

drivers for control of standalone instruments via GPIB, VXI, or serial 
interfaces. You also can submit a request for a particular instrument 
driver if it does not already appear in the library.

• Example Programs Database—A database with numerous, 
non-shipping example programs for National Instruments 
programming environments. You can use them to complement the 
example programs that are already included with National Instruments 
products.

• Software Library—A library with updates and patches to application 
software, links to the latest versions of driver software for National 
Instruments hardware products, and utility routines.

Worldwide Support
National Instruments has offices located around the globe. Many branch 
offices maintain a Web site to provide information on local services. You 
can access these Web sites from www.natinst.com/worldwide.

If you have trouble connecting to our Web site, please contact your local 
National Instruments office or the source from which you purchased your 
National Instruments product(s) to obtain support.

For telephone support in the United States, dial 512 795 8248. For 
telephone support outside the United States, contact your local branch 
office:

Australia 03 9879 5166, Austria 0662 45 79 90 0, Belgium 02 757 00 20, 
Brazil 011 284 5011, Canada (Ontario) 905 785 0085, 
Canada (Québec) 514 694 8521, China 0755 3904939, 
Denmark 45 76 26 00, Finland 09 725 725 11, France 01 48 14 24 24, 
Germany 089 741 31 30, Hong Kong 2645 3186, India 91805275406, 
Israel 03 6120092, Italy 02 413091, Japan 03 5472 2970, 
Korea 02 596 7456, Mexico (D.F.) 5 280 7625, 
Mexico (Monterrey) 8 357 7695, Netherlands 0348 433466, 
Norway 32 27 73 00, Singapore 2265886, Spain (Madrid) 91 640 0085, 
Spain (Barcelona) 93 582 0251, Sweden 08 587 895 00, 
Switzerland 056 200 51 51, Taiwan 02 2377 1200, 
United Kingdom 01635 523545
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